Задать вопрос
21 декабря, 03:56

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены жирным шрифтом).

Вычисление суммы положительных чисел.

Введите количество суммируемых чисел - > 20

Сумма первых 20 положительных чисел равна 210

+1
Ответы (1)
  1. 21 декабря, 04:04
    0
    program zad4;

    uses crt;

    var

    s, i, n: integer;

    begin

    clrscr;

    writeln ('Вычисление суммы первых n положительных чисел') ;

    writeln ('введите количество суммируемых чисел') ;

    readln (n) ;

    s:=0;

    for i:=1 to n do

    begin

    If n mod i = 0 then

    s:=s+n;

    end;

    writeln ('сумма первых ', n,' положительных чисел равна ', s) ;

    readln;

    end.

    Попробуй как-то так
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы