Задать вопрос
17 мая, 11:28

Легенда о происхождении шахмат: мудрец попросил у раджи плату: за первую клетку доски - 1 рисовое зерно, за каждую следующую - вдвое больше, чем за предыдущую.

Написать программу, подсчитывающую количество зёрен, которое раджа должен был заплатить всего за первые 20 клеток шахматной доски.

+1
Ответы (1)
  1. 17 мая, 12:44
    0
    Program radga; var count: integer; i: integer; begin count : = 1; for i: = 1 to 20 do begin count: = count * 2; end; writeln (count) ; end.

    вроде так, не понял одно: нужно было умножать или добавлять так что попробовал умножить)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Легенда о происхождении шахмат: мудрец попросил у раджи плату: за первую клетку доски - 1 рисовое зерно, за каждую следующую - вдвое ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы