Задать вопрос
25 декабря, 00:49

Написать программу которая считает количество цифр в числе и их сумму. паскаль. число вводится с клавиатуры

+5
Ответы (1)
  1. 25 декабря, 04:20
    0
    Для натуральных чисел:

    var a, k, s:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    k:=0; s:=0;

    while a>0 do

    begin

    k:=k+1;

    s:=s+a mod 10;

    a:=a div 10;

    end;

    writeln ('k = ', k,', s = ', s) ;

    end.

    Пример:

    a = 352186

    k = 6, s = 25
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу которая считает количество цифр в числе и их сумму. паскаль. число вводится с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы