Задать вопрос
11 августа, 15:56

Помогите написать программу для решения этой задачи на паскале:"хватит ли N = 180 штук кафельной плитки шириной A = 0,2 м шириной B=0,3 м для покрытия пола в помещении площадью S=12 м²?"

+2
Ответы (1)
  1. 11 августа, 16:47
    0
    Var a, b, s:real; n:integer;

    begin

    n:=180;

    s:=12;

    a:=0.2;

    write ('Ширина ', a:3:1,' - ') ;

    if a*a*n>=s then writeln ('Yes')

    else writeln ('No') ;

    b:=0.3;

    write ('Ширина ', b:3:1,' - ') ;

    if b*b*n>=s then writeln ('Yes')

    else writeln ('No') ;

    end.

    Результат:

    Ширина 0.2 - No

    Ширина 0.3 - Yes
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу для решения этой задачи на паскале:"хватит ли N = 180 штук кафельной плитки шириной A = 0,2 м шириной B=0,3 м ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы