Задать вопрос
16 марта, 00:37

Проходим цикл с предусловием. Нужно составить в Pascal 2 программы.

1) Дано натуральное число n. Написать программу для вычисления суммы членов последовательности 10,15,20 ... n

2) Вывести степени двойки от 1 до n.

+5
Ответы (1)
  1. 16 марта, 00:57
    0
    1)

    var a, n, sum:integer;

    begin

    read (n) ;

    a:=10;

    sum:=0;

    while (a n)

    begin

    sum : = sum + a;

    a : = a+5;

    end;

    end.

    2)

    var n:integer;

    begin

    read (n) ;

    for var i : = 1 to n do writeln (power (2, i)) ;

    end.

    ПаскальАБС. Нет - версия Паскаля, нужен фраемфорк. нет в Паскале, если не работает - обнови паскаль
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Проходим цикл с предусловием. Нужно составить в Pascal 2 программы. 1) Дано натуральное число n. Написать программу для вычисления суммы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы