Задать вопрос
5 ноября, 03:43

Напишите программу для Паскаля для перестановки максимального и минимального по значению элементов массива. Значения длины массива вводятся с клавиатуры

+1
Ответы (1)
  1. 5 ноября, 05:38
    0
    Var a:array of integer;

    n, i, min, imin, max, imax:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    SetLength (a, n) ;

    for i:=0 to n-1 do

    begin

    a[i]:=random (51) ;

    write (a[i]:4) ;

    end;

    writeln;

    min:=a[0]; imin:=0;

    max:=a[0]; imax:=0;

    for i:=1 to n-1 do

    begin

    if a[i]
    begin

    min:=a[i]; imin:=i;

    end;

    if a[i]>max then

    begin

    max:=a[i]; imax:=i;

    end

    end;

    writeln ('min = ', min,' max = ', max) ;

    a[imin]:=max; a[imax]:=min;

    for i:=0 to n-1 do write (a[i]:4) ;

    writeln;

    end.

    Пример:

    n = 10

    33 17 33 49 3 2 14 25 35 47

    min = 2 max = 49

    33 17 33 2 3 49 14 25 35 47
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу для Паскаля для перестановки максимального и минимального по значению элементов массива. Значения длины массива вводятся ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы