Задать вопрос
23 октября, 10:14

Помогите решить задачи на цикл с параметром.

Решения оформить как в Паскале.

1) задать 5 чисел. найти среднюю сумму положительных чисел, произведение чисел, некратных 12 и количество четных чисел среди заданных

2) В фирме работают 5 сотрудников. какую сумму нужно заказать в банке для выплаты им заработной платы, если их зарплата меняется каждый месяц и задаётся бухгалтером с клавиатуры?

3) Задать 20 чисел. найти среднее произведение чисел, больших 8 и сумму чисел, некратных 15.

+4
Ответы (1)
  1. 23 октября, 12:04
    0
    1-задача

    var A:array[1 ... 5] of integer;

    s, P, K, i, c : integer;

    begin

    for I:=1 to 5 do begin

    write ('ведите число ') ;

    readln (A[i]) ;

    end;

    S:=0; c:=0;

    P:=1; K:=0;

    for I:=1 to 5 do begin

    if a[i]>0 then begin S:=S+A[i]; c:=c+1; end;

    if (a[i] mod 12) 0 then P:=P*A[i];

    if (a[i]mod 2) = 0 then K:=K+1;

    end;

    writeln ('средняя сумма положительных чисел = ', S/c) ;

    writeln ('произведение чисел не кратных 12 = ', P) ;

    writeln ('количество чётных чисел = ', k) ;

    end.

    можно сделать и с одним циклом. если надо - отпишись.

    задача 2

    расчёт с учётом того что у сотрудников разная ЗП

    тоже можно сделать с одним циклом.

    var A:array[1 ... 5] of integer;

    i, zp:integer;

    begin

    for I:=1 to 5 do begin

    write ('ведите зарплату сотрудника ', i,': ') ;

    readln (A[i]) ;

    end;

    ZP:=0;

    for I:=1 to 5 do ZP:=ZP+A[i];

    write ('общая сумма=', ZP) ;

    end.

    задача 3

    var A:array[1 ... 20] of integer;

    i, P, S, summ:integer;

    begin

    for I:=1 to 20 do begin

    write ('ведите число ') ;

    readln (A[i]) ;

    end;

    P:=1; S:=0; Summ:=0;

    for I:=1 to 20 do begin

    if A[i]>8 then begin P:=P*a[i]; S:=S+1; end;

    if (A[i]mod 15) 0 then summ:=summ+A[i];

    end;

    writeln ('среднее произведение чисел больше 8 = ', P/S) ;

    write ('семма чисел не кратных 15 = ', summ) ;

    end.

    и это тоже можно с одним циклом
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить задачи на цикл с параметром. Решения оформить как в Паскале. 1) задать 5 чисел. найти среднюю сумму положительных чисел, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Информатика 8 класс Найдите сумму чётных чисел и произведение нечётных чисел введённых с клавиатуры количество чисел задается с клавиатуры
Ответы (1)