Задать вопрос
20 сентября, 18:34

Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран:

а) количество считанных десятичных цифр;

б) количество четных цифр;

в) количество нечетных цифр;

+1
Ответы (1)
  1. 20 сентября, 21:28
    0
    Var

    i, n, x, y, z:integer;

    s:string;

    begin

    readln (s) ;

    for i:=1 to length (s) do

    if (47
    begin

    n:=StrToInt (s[i]) ;

    case n of 0 ... 9:

    begin

    x:=x+1;

    if n mod 2=0 then y:=y+1 else z:=z+1

    end

    end

    end;

    writeln ('Число цифр: ', x,'; четных цифр: ', y,'; нечетных цифр: ', z)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран: а) количество считанных десятичных цифр; ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы