Задать вопрос
31 июля, 17:28

Решить двумя способами. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. Пример: Введите число? 311 Единиц: 2

+3
Ответы (1)
  1. 31 июля, 19:24
    0
    Program n1;

    var num, k: integer;

    begin

    write ('Введите число ') ;

    readln (num) ;

    k:=0;

    while num0 do

    begin

    if abs (num mod 10) = 1 then

    k:=k+1;

    num:=num div 10;

    end;

    writeln ('Единиц: ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить двумя способами. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы