Задать вопрос
12 сентября, 21:56

Помогите с Паскалем. Надо составить программу.

1) У наибольшего из чисел x, y, z найти цифру младшего разряда (единиц) и остаток от его деления на 3.

2) Написать программу, которая по номеру дня недели выдаёт количество уроков на следующий день.

+4
Ответы (2)
  1. 12 сентября, 23:08
    0
    2. var n: Integer;

    Begin

    readln (n) ;

    write ('Уроков ') ;

    case n of

    1: writeln ('6') ;

    2: writeln ('6') ;

    3: writeln ('6') ;

    4: writeln ('5') ;

    5: writeln ('5') ;

    6: writeln ('нет') ;

    7: writeln ('6') ;

    end;

    End.
  2. 12 сентября, 23:26
    0
    Согласно первому заданию надо сначала найти максимальный элемент

    uses crt;

    var x, y, z, max:integer;

    Begin

    writeln ('Введите x y z') ;

    readln (x, y, z) ;

    if (x>y) and (x>z)

    then max:=x

    else

    if (y>x) and (y>z)

    then max:=y

    else max:=z;

    Writeln ('max = ', max) ;

    Writeln ('Младший разряд = ', max mod 10) ;

    Writeln ('Остаток от деления на 3 = ', (max mod 10) mod 3) ;

    readln;

    end.

    2)

    var n: Integer;

    Begin

    writeln ('Введите день недели') ;

    readln (n) ;

    write ('Уроков ') ;

    case n of

    1-4: writeln ('6') ;

    5,6: writeln ('5') ;

    7: writeln ('нет') ;

    end;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с Паскалем. Надо составить программу. 1) У наибольшего из чисел x, y, z найти цифру младшего разряда (единиц) и остаток от его ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы