Задать вопрос
14 апреля, 16:36

Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр.

+1
Ответы (1)
  1. 14 апреля, 16:56
    0
    Var

    sum, com, n:integer;

    begin

    Read (n) ; sum:=0; com:=1;

    while (n > 0) do begin

    sum: = sum + n mod 10;

    com: = com * (n mod 10) ;

    n: = n div 10;

    end;

    Writeln ('Сумма - > ', sum) ;

    Writeln ('Произведение - > ', com) ;

    end.

    Пример:

    1234

    Сумма - > 10

    Произведение - > 24
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы