Задать вопрос
10 декабря, 13:35

Напишите программу реализующую калькулятор на 4 арифметических действия. На языке паскаль

+4
Ответы (1)
  1. 10 декабря, 16:20
    0
    Program test;

    var

    a, b:integer;

    rezultat:real;

    sign:char;

    begin

    rezultat:=0;

    writeln ('Введите числа a, b: ') ;

    readln (a, b) ;

    writeln ('Введите знак операции: ') ;

    readln (sign) ;

    case sign of

    '+': rezultat:=a+b;

    '-': rezultat:=a-b;

    '*': rezultat:=a*b;

    '/': rezultat:=a/b else writeln ('An error occurred: Invalid operation! Try again!') ;

    end;

    writeln (rezultat) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу реализующую калькулятор на 4 арифметических действия. На языке паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы