Задать вопрос
6 марта, 00:37

Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n

Вот пример из задачи:

Написать пр-му, которая выводит все натуральные числа от 1 до n

Program zd;

var i, n: integer;

Begin

Writeln ('Введите n') ;

readln (n) ;

for i:=i to n do

begin

writeln (i,' ') ;

end;

end.

+5
Ответы (1)
  1. 6 марта, 03:50
    0
    Program n1;

    var n, sum, i: integer;

    begin

    readln (n) ;

    sum:=0;

    for i:=1 to n do sum:=sum+i;

    write ('сумма: ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая подсчитает сумму натуральных чисел от 1 до n Вот пример из задачи: Написать пр-му, которая выводит все ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы