Задать вопрос
31 марта, 11:32

Найти максимальный среди всех элементов тех строк заданной матрицы, которые упорядочены (либо по возрастанию, либо по убыванию).

Составить программу в Pascal.

+1
Ответы (1)
  1. 31 марта, 13:29
    0
    При использовании random () упорядоченные строки получаются редко. Можете массив вводить с клавиатуры.

    const n=5; m=4;

    var

    a:array[1 ... n, 1 ... m] of integer;

    i, j, max:integer;

    b1, b2:boolean;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (100) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    max:=-1000;

    for i:=1 to n do

    begin

    b1:=true; b2:=true;

    for j:=1 to m-1 do

    begin

    if a[i, j]
    if a[i, j]>a[i, j+1] then b2:=false;

    end;

    if b1 or b2 then

    for j:=1 to m do

    if a[i, j]>max then max:=a[i, j];

    end;

    if max-1000

    then writeln ('max = ', max)

    else writeln ('В массиве нет упорядоченных строк') ;

    end.

    Пример:

    45 34 88 53

    2 7 36 71

    48 57 28 42

    75 61 10 93

    15 3 61 54

    max = 71
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти максимальный среди всех элементов тех строк заданной матрицы, которые упорядочены (либо по возрастанию, либо по убыванию). Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы