Задать вопрос
25 августа, 09:14

Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 (F 1 = F 2 = 1), а каждое следующее равно сумму двух предыдущих: F n = F n - 1

+ F n - 2. Напишите программу, которая вводит натуральное число N и выводит на экран первые N числа Фибаначчи

+5
Ответы (1)
  1. 25 августа, 10:09
    0
    1 var a, b, c, n, i: integer;

    2

    3 begin

    4 writeln ('Vvedite N') ;

    5 readln (n) ;

    6 a : = 1; b : = 1;

    7 for i : = 3 to n do begin

    8 c : = a + b;

    9 a : = b;

    10 b : = c;

    11 end;

    12 writeln (c) ;

    13 end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 (F 1 = F 2 = 1), а каждое следующее равно сумму двух предыдущих: F ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Задача А Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух предыдущих. Дано натуральное число N (2< N < 2*10^9). Найти два ближайших к нему числа Фибоначчи.
Ответы (1)
Последовательность Фибоначчи определяется следующим образом: первые два члена последовательности равны 1, а каждый следующий равен сумме двух предыдущих. То есть числами Фибоначчи являются 1,1,2,3,5,8,13, ... Вводится натуральное число.
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)