Задать вопрос
4 сентября, 15:16

Помогите написать программу в Паскале и блок-сxему.

Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.

+4
Ответы (1)
  1. 4 сентября, 16:47
    0
    Var a, b, i: real;

    begin

    b:=0,5;

    for i = 1 to 10 do

    begin

    readln (a) ;

    if a<0 then

    writeln (a)

    else

    a:=a-b;

    writeln (a) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в Паскале и блок-сxему. Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы