Задать вопрос
17 апреля, 09:04

Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое.

+3
Ответы (1)
  1. 17 апреля, 10:45
    0
    Var a, i, b:integer;

    s:real;

    begin

    a:=0;

    for i:=1 to 10 do begin

    b:=random (20) + 1;

    a+=b;

    write (b,' ') ;

    end;

    writeln;

    s:=a/10;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы