Задать вопрос
7 декабря, 05:05

Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная.

Формат ввода

В входном файле находится одно четырехзначное число.

Формат вывода

В выходной файл следует вывести сообщение "YES", если сумма цифр число четная или "NO", если сумма не четная.

+3
Ответы (1)
  1. 7 декабря, 06:47
    0
    Var

    a:array[1 ... 4] of integer;

    s, i:integer;

    begin

    while i < 4 do begin

    i+=1;

    read (a[i]) ;

    s+=a[i];

    end;

    if frac (s/2) = 0 then write ('yes')

    else write ('not') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная. Формат ввода В входном файле находится одно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы