Задать вопрос
10 марта, 03:39

Написать программу в Pascal, используя массивы.

Дано массив А[1 ... n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки

Желательно с обьяснением строк

+1
Ответы (1)
  1. 10 марта, 04:32
    0
    Const

    n = 100;

    var

    a: array[1 ... n] of integer;

    i: integer;

    begin

    //заполняем массив случайными значениями в диапазоне [0; 100]

    Randomize; / / инициализация датчика случайных чисел

    for i : = 1 to n do a[i] : = random (100) ;

    i : = 1; / / 1 - это два в нулевой степени

    while i < n do

    begin

    writeln ('a (', i, ') = ', a[i]) ;

    i : = 2 * i; / / удваиваем индекс, чтобы получить очередную степень двойки

    end

    end.

    Результат работы программы:

    a (1) = 26

    a (2) = 21

    a (4) = 29

    a (8) = 74

    a (16) = 23

    a (32) = 44

    a (64) = 20
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Pascal, используя массивы. Дано массив А[1 ... n]. Сделать программу которая выводит те элементы массива? индексы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы