Задать вопрос
4 февраля, 19:32

Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от - 20 до 20. Написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.

+3
Ответы (1)
  1. 4 февраля, 23:11
    0
    Var a, b, i:integer;

    n:real;

    mass:array[1 ... 31] of integer;

    begin

    for i:=1 to 31 do begin

    mass[i]:=random (40) - 20;

    if mass[i]>0 then begin

    b:=b+1;

    a:=a+mass[i];

    end;

    end;

    writeln ('Полученные значения') ;

    for i:=1 to 31 do

    write (mass[i]:4) ;

    n:=a/b;

    writeln;

    writeln ('Средняя температура равна ', n:3:1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от - 20 до 20. Написать программу, которая выводит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы