Задать вопрос
19 ноября, 20:53

Помогите написать программу на Pascal, условие: даны три действительных числа. возвести в квадрат те из них, значения которых неотрицательны.

+4
Ответы (1)
  1. 19 ноября, 22:25
    0
    Var a, b, c: real;

    Begin

    Readln (a, b, c) ;

    if (a>0) then a:=a*a;

    if (b>0) then b:=b*b;

    if (c>0) then c:=c*c;

    Writeln (a,' ', b,' ', c) ;

    Readln (a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на Pascal, условие: даны три действительных числа. возвести в квадрат те из них, значения которых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы