Задать вопрос
18 февраля, 11:48

Написать программу поиска суммы положительных чисел, вводимых с клавиатуры. Как

только будет введено отрицательное число, суммирование прекратить.

+4
Ответы (1)
  1. 18 февраля, 14:47
    0
    Var

    A, S: real;

    Begin

    S : = 0;

    Write ('Введите последовательность чисел: ') ;

    Read (A) ;

    While A > = 0 do

    Begin

    S : = S + A;

    Read (A) ;

    End;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу поиска суммы положительных чисел, вводимых с клавиатуры. Как только будет введено отрицательное число, суммирование ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы