Задать вопрос
31 мая, 08:31

Помогите!

Помогите решить!

1) Какие из описаний могут быть именами переменных

a) 4_с

b) sum

c) b 3

d) one_а

2) Какая команда в Pascal-е служит для того, чтобы задать какой-либо переменной значение до выполнения алгоритма? Приведите пример.

3) Найдите и исправьте ошибки в следующей программе:

program prim_a;

var m, n, k: integer;

writeln ('введите значения переменных m и n') ;

red (m, n, k) ;

writeln (m+n+k) ;

end.

4) Напишите программу для решения одной из двух задач:

a) Найти площадь и периметр прямоугольника со сторонами а и b.

b) Найти значение выражения:

5) Напишите программу для нахождения суммы крайних цифр трехзначного числа.

+3
Ответы (1)
  1. 31 мая, 09:58
    0
    1)

    a) не может, потому что переменные должны всегда начинаться с буквы

    b) может

    c) не может, слова могут быть разделены только знаком "_", не пробелом!

    d) может

    2) присваивание, обозначается знаком "="

    Например:

    sum = 0;

    3)

    4 строка - не red, а read

    пропущена трока между 2 и 3 строчкой - это begin

    4)

    var

    S, P, a, b: integer

    begin

    write ('Введите сторону а: ') ;

    readln (a) ;

    write ('Введите сторону b: ') ;

    readln (b) ;

    S = a * b; {нахидим площадь}

    P = (a + b) * 2; {находим периметр}

    writeln ('Площадь = ', S, ', периметр = ', P) ;

    end.

    5)

    Var

    number, {Трехзначное число}

    num1, {Первая крайняя цифра}

    num2, {Вотрая крайняя цифра}

    : integer;

    Begin

    write ('Введите число') ;

    readln (number) ;

    num1 = number mod 10;

    num2 = number div 100;

    writeln ('Сумма крайних цифр числа ', number, ' = ', num1 + num2) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите! Помогите решить! 1) Какие из описаний могут быть именами переменных a) 4_с b) sum c) b 3 d) one_а 2) Какая команда в Pascal-е ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы