Задать вопрос
25 марта, 18:15

В Паскале с помощью repeat. Составьте программу, которая выводит на экран сумму нечетных чисел от 36 до 66.

+4
Ответы (1)
  1. 25 марта, 19:55
    0
    Begin

    Writeln (((65+37) * ((65-37) div 2 + 1)) div 2) ;

    end.

    Или более универсально:

    Var A, B : Integer;

    Begin

    Readln (A, B) ;

    Inc (A, Ord (not Odd (A))) ;

    Dec (B, Ord (not Odd (B))) ;

    Writeln (((B+A) * ((B-A) div 2 + 1)) div 2) ;

    end.

    А если строго по заданию, то так:

    Var S, i : Integer;

    Begin

    s:=0; i:=37;

    Repeat

    s:=s+i;

    Inc (i, 2) ;

    Until i>65;

    Writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В Паскале с помощью repeat. Составьте программу, которая выводит на экран сумму нечетных чисел от 36 до 66. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы