Задать вопрос
3 февраля, 05:03

Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры

+2
Ответы (1)
  1. 3 февраля, 08:52
    0
    Var a:array[1 ... 3] of integer;

    i, sum, col:integer;

    begin

    sum:=0;

    col:=0;

    for i:=1 to 3 do readln (a[i]) ;

    for i:=1 to 3 do

    if a[i]>0 then

    begin

    col:=col+1;

    sum:=sum+a[i];

    end;

    writeln ('Сумма: ', sum) ;

    writeln ('Кол-во: ', col) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы