Задать вопрос
2 июня, 15:56

Получить квадратную матрицу порядка n:

k 0

n-1 n

n-2 n-1 n

...

1 2 3 ... n

Может кто знает как написать программу в Паскале?

+4
Ответы (1)
  1. 2 июня, 16:25
    0
    Const n=6;

    var a:array[1 ... n, 1 ... n] of integer;

    i, j:integer;

    begin

    for i:=1 to n do

    for j:=1 to i do a[i, j]:=n-i+j;

    for i:=1 to n do

    begin

    for j:=1 to n do write (a[i, j]:3) ;

    writeln;

    end;

    end.

    Пример:

    6 0 0 0 0 0

    5 6 0 0 0 0

    4 5 6 0 0 0

    3 4 5 6 0 0

    2 3 4 5 6 0

    1 2 3 4 5 6
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Получить квадратную матрицу порядка n: k 0 n-1 n n-2 n-1 n ... 1 2 3 ... n Может кто знает как написать программу в Паскале? ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы