Задать вопрос
9 июля, 12:46

Написать программу while ... do

Ввести с клавиатуры 10 чисел. Если квадрат числа меньше 100, напечатать число и его квадрат.

+4
Ответы (1)
  1. 9 июля, 14:10
    0
    Одно из возможных решений. Также можно использовать массив, если это необходимо за условием.

    const

    n = 10;

    var

    i, number: integer;

    begin

    i : = 1;

    while (i < = n) do

    begin

    write ('Введите ', i, '-ое число: ') ;

    readln (number) ;

    if sqr (number) < 100 then

    writeln ('Число: ', number, '. Квадрат числа: ', sqr (number), '.') ;

    Inc (i) ;

    end

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу while ... do Ввести с клавиатуры 10 чисел. Если квадрат числа меньше 100, напечатать число и его квадрат. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы