Задать вопрос
22 сентября, 23:48

Даны два числа, если 1>2, то составить программу для нахождения среднего арефметического. Если 2>1, то для нахождения среднего геометрического.

Можно в паскале

+4
Ответы (1)
  1. 23 сентября, 00:52
    0
    Var sa, sg, a, b:real;

    begin

    write ('a: ') ;

    readln (a) ;

    write ('b: ') ;

    readln (b) ;

    sa: = (a+b) / 2;

    sg:=sqrt (a*b) ;

    if a>b then writeln (sa)

    else writeln (sg) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны два числа, если 1>2, то составить программу для нахождения среднего арефметического. Если 2>1, то для нахождения среднего ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы