Задать вопрос
10 сентября, 23:23

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс

+1
Ответы (1)
  1. 11 сентября, 00:21
    0
    Const

    m=10;

    n=8;

    var

    a:array[1 ... m, 1 ... n] of integer;

    i, j:integer;

    p:double;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=Random (101) - 50;

    Write (a[i, j]:4) ;

    end;

    Writeln

    end;

    p:=1;

    for j:=1 to n do

    if a[3, j]>0 then p:=p*a[3, j];

    Writeln ('Искомое произведение: ', p)

    end.

    Тестовое решение:

    Исходный массив

    35 30 35 - 25 - 50 8 - 20 47

    -34 - 26 - 7 34 - 9 - 31 10 - 46

    -17 - 21 27 8 27 41 35 - 48

    30 - 44 25 48 30 - 20 10 - 6

    -3 - 10 45 - 33 3 - 38 - 11 - 8

    47 - 25 - 27 - 7 2 - 20 - 4 - 48

    -38 32 - 29 - 41 31 16 46 44

    45 33 - 4 45 34 - 18 - 33 37

    15 49 - 14 - 49 - 25 - 8 1 - 30

    41 - 15 11 1 17 - 8 0 - 1

    Искомое произведение: 8368920
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы