Задать вопрос
17 июля, 12:57

Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.

+5
Ответы (1)
  1. 17 июля, 15:17
    0
    Var a:integer;

    begin

    writeln ('a=') ;

    readln (a) ;

    if (a>0) then writeln ('cislo polojitelinoe', a/2) else

    writeln ('cislo otritatelinoie', sqr (a)) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы