Задать вопрос
10 июля, 03:27

Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. Получить новую последовательность путем замены всех ненулевых

элементов исходной последовательности на разность между элементом последовательности и найденной суммой.

+2
Ответы (1)
  1. 10 июля, 07:26
    0
    Program Project1;

    var

    a:array[1 ... 5] of Integer;

    i, j, sum:Integer;

    s:string;

    begin

    Readln (s) ;

    sum:=0;

    for i:=1 to 5 do

    begin

    if (Length (s) >=2) then

    begin

    j:=Pos (' ', s) ;

    a[i]:=StrToInt (Copy (s, 1, j-1)) ;

    sum:=sum+a[i];

    Delete (s, 1, j) ;

    end

    else

    begin

    a[i]:=StrToInt (s) ;

    sum:=sum+a[i];

    end;

    end;

    for i:=1 to 5 do

    begin

    if (a[i]0) then

    begin

    a[i]:=a[i]-sum;

    Write (a[i], ' ') ;

    end

    else

    begin

    a[i]:=a[i];

    Write (a[i], ' ') ;

    end;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. Получить новую последовательность путем замены ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы