Задать вопрос
21 июня, 00:06

С клавиатуры вводится натуральное число, не превосходящее 1000. Представить его в виде соответствующей словесной записи в паскале

+2
Ответы (1)
  1. 21 июня, 01:18
    0
    Var

    m, n: integer;

    ms: array[1 ... 9] of string;

    md: array[1 ... 9] of string;

    m1: array[11 ... 19] of string;

    me: array[1 ... 9] of string;

    flag: boolean;

    begin

    flag : = false; { Пока ничего не выведено }

    ms[1] : = 'сто'; ms[2] : = 'двести'; ms[3] : = 'триста'; ms[4] : = 'Четыреста';

    ms[5] : = 'пятьсот'; ms[5] : = 'пятьсот'; ms[6] : = 'шестьсот'; ms[7] : = 'семьсот';

    ms[8] : = 'восемьсот'; ms[9] : = 'девятьсот';

    md[1] : = 'десять'; md[2] : = 'двадцать'; md[3] : = 'тридцать'; md[4] : = 'сорок';

    md[5] : = 'пятьдесят'; md[6] : = 'шестьдесят'; md[7] : = 'семьдесят';

    md[8] : = 'восемьдесят'; md[9] : = 'девяносто';

    m1[11] : = 'одиннадцать'; m1[12] : = 'двенадцать'; m1[13] : = 'тринадцать';

    m1[14] : = 'четырнадцать'; m1[15] : = 'пятнадцать'; m1[16] : = 'шестнадцать';

    m1[17] : = 'семнадцать'; m1[18] : = 'восемнадцать'; m1[19] : = 'девятнадцать';

    me[1] : = 'один'; me[2] : = 'два'; me[3] : = 'три'; me[4] : = 'четыре'; me[5] : = 'пять';

    me[6] : = 'шесть'; me[7] : = 'семь'; me[8] : = 'восемь'; me[9] : = 'девять';

    Write ('Введите целое число от 1 до 1000: ') ;

    Readln (m) ;

    if (m 1000) then Writeln ('Шутки шутим?')

    else

    if m = 1000 then Writeln ('Одна тысяча ')

    else

    begin

    { сотни }

    n : = m div 100;

    if n > 0 then

    begin

    Write (ms[n]) ;

    flag : = true

    end;

    { десятки }

    m : = m mod 100;

    if m = 0 then Writeln (' ')

    else

    begin

    if (m > 10) and (m < 20) then

    begin

    if flag then Write (' ') ;

    Writeln (m1[m])

    end

    else

    if m > 0 then

    begin

    n : = m mod 10;

    m : = m div 10;

    if m > 0 then

    begin

    if flag then Write (' ') else flag : = true;

    Write (md[m])

    end;

    if n 0 then

    begin

    { единицы }

    if flag then Write (' ') ;

    Write (me[n]) ;

    end

    end

    end

    end

    end.

    Тестовое решение:

    Введите целое число от 1 до 1000: 429

    Четыреста двадцать девять
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводится натуральное число, не превосходящее 1000. Представить его в виде соответствующей словесной записи в паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)
Требовалось написать программу, при выполнении которой с клавиатуры вводится натуральное число, не превосходящее 10^8, и выводится его первая цифра.
Ответы (1)