Задать вопрос
27 декабря, 02:13

1. Записать на языке паскаль выражение:

| x² - 20 | / cos y + 5x √y

2. Чему равны значения переменных t и r после исполнения фрагмента программы:

t : = 1

if r >10then r:=r+1; t:=8;

a) (1,56) при r = 17;

б) (2 б) при r = 9.

3. Сколько раз выполнится цикл и что будет на экране после исполнения фрагмента программы.

for i: = - 10 to - 9 do

begin k:=i; write (k) ; end.

4. Магазин установил скидки покупателям за сумму покупок: от 5 тысяч руб. - 0.5 % от 10 тысяч руб. - 2 %, начиная от 20 тысяч руб. - 5 % сяч з

а) Составить программу, которая для введенного целого числа (количества тысяч за покупку) выводит на экран процент скидки.

б) Составить программу, которая для 10 введенных с клавиатуры чисел (количества тысяч руб. за покупку 10 покупателей) выводит на экран процент скидки до каждого.

+1
Ответы (1)
  1. 27 декабря, 02:30
    0
    1)

    abs (x*x - 20) / Cos (y) + 5*x*sqrt (y)

    2)

    t : = 1

    if r >10then r:=r+1; t:=8;

    a)

    При r=17 условие выполняется, значит r увеличится на единицу.

    Команды не связаны операторными скобками (begin r:=r+1; t:=8; end),

    поэтому t:=8; выполнится безусловно.

    r=18; t=8;

    б)

    При r = 9 условие не выполняется, поэтому значение r останется неизменным.

    r = 9; t = 8;

    3)

    for i: = - 10 to - 9 do

    begin k:=i; write (k) ; end.

    Цикл For не выполнится ни разу. На экран не будет выведено ничего.

    Цикл "For i: = A to B do" выполняется B-A+1 раз, при условии, что B>=A.

    В нём значение i меняется от A до B, с каждой итерацией прибавляется единица.

    Цикл "For i: = A downto B do" выполнится A-B+1 раз, при условии, что A>=B

    В нём значение i тоже меняется от A до B, но с каждой итерацией от i отнимается единица.

    4)

    а)

    Var

    A:integer;

    Begin

    Write ('Введите сумму покупок: ') ; ReadLn (A) ;

    if A<5 then Write ('Скидка не предоставляется')

    else if (A>=5) and (A<10) then Write ('Скидка: 0.5%')

    else if (A>=10) and (A<20) then Write ('Скидка: 2%')

    else Write ('Скидка: 5%')

    End.

    б)

    Var

    A, i:integer;

    Begin

    For i: = 1 to 10 do

    Begin

    Write ('Введите сумму покупок: ') ;

    ReadLn (A) ;

    if A<5 then WriteLn ('Скидка не предоставляется')

    else if (A>=5) and (A<10) then WriteLn ('Скидка: 0.5%')

    else if (A>=10) and (A<20) then WriteLn ('Скидка: 2%')

    else WriteLn ('Скидка: 5%')

    End

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Записать на языке паскаль выражение: | x² - 20 | / cos y + 5x √y 2. Чему равны значения переменных t и r после исполнения фрагмента ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы