Задать вопрос
18 ноября, 14:43

Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа

+5
Ответы (1)
  1. 18 ноября, 16:17
    0
    Var a, b, x, s:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    write ('x = ') ;

    readln (x) ;

    b:=a;

    s:=0;

    while b>0 do

    begin

    s:=s+b mod 10;

    b:=b div 10;

    end;

    writeln ('s = ', s) ;

    if s>x

    then writeln ('Сумма цифр больше ', x)

    else writeln ('Сумма цифр не больше ', x) ;

    end.

    Пример:

    a = 31854

    x = 15

    s = 21

    Сумма цифр больше 15
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы