Задать вопрос
13 марта, 00:26

Составьте программу записывающую в файл одномерный массив случайных

чисел, а затем считывающую его с диска и выполняющую запись четных элементов

в другой файл (на Паскале)

+2
Ответы (1)
  1. 13 марта, 01:12
    0
    Program untitled;

    var t, t2:text;

    i, a:integer;

    m:array [1 ... 50] of integer;

    begin

    randomize;

    assign (t,'output. txt') ;

    assign (t2,'output2. txt') ;

    rewrite (t) ;

    for i:=1 to 50 do begin

    m[i]:=random (50) ;

    writeln (t, m[i]) ;

    end;

    reset (t) ;

    rewrite (t2) ;

    for i:=1 to 50 do begin

    readln (t, a) ;

    if a mod 2=0 then

    writeln (t2, a) ;

    end;

    close (t) ;

    close (t2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу записывающую в файл одномерный массив случайных чисел, а затем считывающую его с диска и выполняющую запись четных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы