Задать вопрос
15 мая, 21:45

Составить программу, которая запоминает массив а (1 ... 10) случайными числами от 1 о10 затем первый элемент меняет местами с максимальным элементом

+1
Ответы (1)
  1. 16 мая, 01:09
    0
    Var

    a: array [1 ... 10] of integer;

    i, max, s, x: integer;

    begin

    s:=1;

    randomize;

    for i : = 1 to 10 do

    begin

    a[i] : = random (10) + 1

    end;

    writeln (a) ;

    max : = a[1];

    for i : = 1 to 10 do

    begin

    if max < a[i] then begin

    max : = a[i];

    s : = i

    end;

    end;

    x : = a[1];

    a[1] : = a[s];

    a[s] : = x;

    writeln (a)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая запоминает массив а (1 ... 10) случайными числами от 1 о10 затем первый элемент меняет местами с максимальным ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы