Задать вопрос
26 февраля, 17:01

Вопрос №591394 (тип: C)

Даны два целых числа a и b.

Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b

Входные данные:

В первой строке вводятся два целых числа a и b (a<=b, a, b не больше 100 по модулю)

Выходные данные:

Программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой)

+5
Ответы (1)
  1. 26 февраля, 19:22
    0
    Program n1;

    var a, b, i: integer;

    sum, k: real;

    begin

    sum:=0;

    k:=0;

    readln (a, b) ;

    for i:=a to b do

    begin

    sum:=sum+i*i;

    k:=k+1;

    end;

    writeln (sum/k:6:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вопрос №591394 (тип: C) Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы