Задать вопрос
19 августа, 17:29

составьте программу вычисления корней квадратного уравнения aх^2+вх+с=0 по данным значениям его коэффициентов.

+1
Ответы (1)
  1. 19 августа, 19:13
    0
    Var a, b, c, d, x1, x2 : real; / / задание переменных действительных чисел.

    begin

    write ('a = ') ; readln (a) ; / / запрос у пользователя первого коэффициента

    write ('b = ') ; readln (b) ; / / запрос у пользователя второго коэффициента

    write ('c = ') ; readln (c) ; / / запрос у пользователя третьего коэффициента

    d : = b*b - 4*a*c; / / расчет дискриминанта

    if d=0 then / / ветка для решения при нулевом дискриминанте

    begin

    x1 : = b / (2 * a)

    writeln (x1:3:3) ;

    end / / окончание при нулевом дискриминанте

    else

    if d>0 then / / ветка для решения при положительном дискриминанте

    begin

    x1 : = (- b + sqrt (d) / (2 * a) ; / / первый корень

    x2 : = (- b - sqrt (d) / (2 * a) ; / / второй корень

    writeln (x1:3:3, ' ', x2:3:3) ; / / вывод ответа

    end

    else / / ветка решения для отрицательного дискриминанта

    writeln ('Нет действительных корней') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составьте программу вычисления корней квадратного уравнения aх^2+вх+с=0 по данным значениям его коэффициентов. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы