Задать вопрос
2 декабря, 09:53

Составьте программу, которая определяет число разрядов заданного натурального числа N (подсказка: сколько раз должна выполняться N=N div 10, чтобы получилось N=0)

+5
Ответы (1)
  1. 2 декабря, 10:44
    0
    Program n1;

    var c: longint;

    function ch (n: longint) : longint;

    var i: longint;

    begin

    i : = 0;

    while n > 0 do

    begin

    n : = n div 10;

    i : = i + 1

    end;

    ch: = i

    end;

    begin

    write ('Введите число: ') ;

    readln (c) ;

    if c<0 then c:=abs (c) ;

    writeln ('в этом числе ', ch (c),' разрядов ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая определяет число разрядов заданного натурального числа N (подсказка: сколько раз должна выполняться N=N div ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы