Задать вопрос
2 июля, 09:50

Тема: одномерные массивы, написать программу использую rite, riteln

задача; Все элементы кратные трем делятся на три, остальные умножаются на 3.

+4
Ответы (1)
  1. 2 июля, 13:06
    0
    Const N = ...; / / указываешь количество элементов массива

    var a:array [1 ... N] of integer;

    i:integer;

    begin

    for i:=1 to N do

    readln (a[i]) ;

    for i:=1 to N do begin

    if a[i] mod 3 = 0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;

    writeln (a[i]) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Тема: одномерные массивы, написать программу использую rite, riteln задача; Все элементы кратные трем делятся на три, остальные умножаются ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы