Задать вопрос
13 марта, 07:08

Даны координаты трех вершин треугольника. Найти его площадь. Пример. Для вершин (0.0) ; (0,1) ; (1,0) площадь - 0,5.

+3
Ответы (1)
  1. 13 марта, 08:02
    0
    Uses crt;

    var p, a, b, c, xa, xb, xc, ya, yb, yc, ab, ac, bc, xab, yab, xbc, ybc, xac, yac:real;

    s:real;

    begin

    writeln ('Введите х координаты вершин а и b') ;

    readln (xa, xb) ;

    writeln ('Введите y координаты вершин а и b') ;

    readln (ya, yb) ;

    xab:=xb-xa;

    yab:=yb-ya;

    ab:=sqrt (xab*xab+yab*yab) ;

    writeln ('Введите х координаты вершин а и с') ;

    readln (xa, xc) ;

    writeln ('Введите y координаты вершин а и c') ;

    readln (ya, yc) ;

    xac:=xc-xa;

    yac:=yc-ya;

    ac:=sqrt (xac*xac+yac*yac) ;

    writeln ('Введите х координаты вершин b и с') ;

    readln (xb, xc) ;

    writeln ('Введите y координаты вершин b и c') ;

    readln (yb, yc) ;

    xbc:=xc-xb;

    yab:=yc-yb;

    bc:=sqrt (xbc*xbc+ybc*ybc) ;

    p: = (ab+bc+ac) / 2;

    s:=sqrt (p * (p-ab) * (p-bc) * (p-ac)) ;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны координаты трех вершин треугольника. Найти его площадь. Пример. Для вершин (0.0) ; (0,1) ; (1,0) площадь - 0,5. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
Даны координаты трех вершин треугольника : (Х1, у1), (х2, у2), (х3, у3). найти его периметр и площадь, используя формулу для расстояния между двумя точками на плоскости.
Ответы (1)
C#. Даны координаты трех вершин прямоугльника. Найти координаты четвертой вершины.
Ответы (1)
Составьте для Чертежника алгоритм Составьте для Чертежника алгоритм рисования равнобедренного треугольника, если известны координаты концов отрезка, являющегося его высотой (4, 1) и (4, 6), а также координаты (2, 1) одной из его вершин
Ответы (1)
Паскаль! Даны координаты левой верхней и правой нижней вершин квадрата. Найти координаты точки пересечения диагоналей квадрата.
Ответы (2)