Задать вопрос
26 мая, 02:02

Напишите программу в Pascal для этой задачи:

Найти среднее арифметическое и сумму последовательности положительных чисел

+2
Ответы (1)
  1. 26 мая, 04:41
    0
    Var a, sum, i : integer; s, x : string; sa : real;

    begin sum:=0; readln (s) ; for i:=1 to length (s) do begin x:=copy (s, i, 1) ; val (x, a) ; sum:=sum+a; end; sa:=sum / (length (s)) ; writeln ('сумма: ', sum) ; writeln ('среднее арифметическое: ', sa:4:2) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в Pascal для этой задачи: Найти среднее арифметическое и сумму последовательности положительных чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы