Задать вопрос
29 сентября, 11:52

Для заданного числа N требуется найти наименьшее число, которое начинается с определенной последовательности цифр S и делится на N. (написать программу)

+4
Ответы (1)
  1. 29 сентября, 14:04
    0
    Var n, s, a, m:longint;

    begin

    readln (n, s) ;

    m:=10;

    if s mod n=0 then a:=s else a:=s*10;

    while a mod n0 do

    if a mod m = (m-1)

    then begin m:=m*10; a:=s*m; end

    else a:=a+1;

    writeln (a) ;

    end.

    Пример:

    123 16

    16113
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Для заданного числа N требуется найти наименьшее число, которое начинается с определенной последовательности цифр S и делится на N. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы