Задать вопрос
23 августа, 20:20

Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток. Подсчитать общее количество цифр в этом числе.

+3
Ответы (1)
  1. 23 августа, 23:21
    0
    Program test;

    var i, n, schet:integer; s:string;

    begin

    readln (n) ;

    for i:=1 to n do

    s:=s+inttostr (n) ;

    schet:=length (s) ;

    writeln (schet) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы