Задать вопрос
9 декабря, 00:03

Составить программу в паскале ABC для решения следующей задачи. С клавиатуры вводятся 3 произвольных числа. Если второе число больше суммы первого и третьего, то вывести сумму этих двух чисел. Если первое число положительное, то вывести среднее арифметическое трех чисел.

+1
Ответы (1)
  1. 9 декабря, 02:06
    0
    Program qq;

    uses CRT;

    var x1, x2, x3, sum2, SrArVsChi:integer;

    begin

    write ('Первое число равно ') ;

    readln (x1) ;

    write ('Второе число равно ') ;

    readln (x2) ;

    write ('Третье число равно ') ;

    readln (x3) ;

    if x2 > (x1+x3) then

    sum2:=x1+x3;

    writeln (sum2) ;

    if x1 > = 0 then

    SrArVsChi: = (x1+x2+x3) / 3;

    writeln (SrArVsChi) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в паскале ABC для решения следующей задачи. С клавиатуры вводятся 3 произвольных числа. Если второе число больше суммы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы