Задать вопрос
20 октября, 12:38

Pascal. Составить программу, в которой с помощью оператора while посчитать сумму ряда тех пор пока член ряда не будет меньше 0.005.

+4
Ответы (1)
  1. 20 октября, 14:35
    0
    Const e=0.005;

    var i:integer;

    a, s:real;

    begin

    i:=2;

    a:=5 / (i*i-1) ;

    s:=0;

    while a>=e do

    begin

    s:=s+a;

    i:=i+1;

    a:=5 / (i*i-1) ;

    end;

    writeln ('i = ', i,' s = ', s) ;

    end.

    Результат:

    i = 32 s = 3.59122983870968
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal. Составить программу, в которой с помощью оператора while посчитать сумму ряда тех пор пока член ряда не будет меньше 0.005. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы