Задать вопрос
29 марта, 00:13

Умоляю, помогите с Паскалем

1. Пользователь вводит неотрицательное однозначное число A. Написать программу:

вычисляющую в случае ввода 1 - площадь круга с радиусом A,

вычисляющую в случае ввода 2 - площадь квадрата со стороной A,

вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,

выдающую сообщение "нужно ввести число 1, 2, 3" в остальных случаях.

+2
Ответы (1)
  1. 29 марта, 02:29
    0
    1) по заданному радиусу: Program n1;

    Uses CRT;

    Var r, s: real;

    begin

    ClrScr;

    writeln ('Vvedite radius') ;

    readln (r) ;

    s:=r*r*pi;

    Writeln ('ploshad = ', s:4:4) ;

    readln

    end. 2) по заданным сторонам: Program n1;

    Uses CRT;

    Var a, b, s: real;

    begin

    ClrScr;

    writeln ('Vvedite storoni') ;

    readln (a, b) ;

    s:=a*b;

    Writeln ('ploshad = ', s:4:4) ;

    readln

    end. 3) по заданной стороне Program n1;

    Uses CRT;

    Var a, s: real;

    begin

    ClrScr;

    writeln ('Vvedite storony') ;

    readln (a) ;

    s:=a*a;

    Writeln ('ploshad = ', s:4:4) ;

    readln

    end. 3) по одной стороне и высоте к ней: Program n1;

    Uses CRT;

    Var a, b, s: real;

    begin

    ClrScr;

    writeln ('Vvedite storony i vysoty k nei') ;

    readln (a, b) ;

    s:=a*b;

    Writeln ('ploshad = ', s:4:4) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы