Задать вопрос
11 февраля, 14:56

Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали.

Входные данные

В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100). В следующих N строках записаны строки матрицы, в каждой - по N натуральных чисел, разделённых пробелами.

Выходные данные

Программа должна вывести матрицу, у которой все элементы выше главной диагонали нулевые, а остальные элементы такие же, как в исходной матрице.

+1
Ответы (1)
  1. 11 февраля, 16:12
    0
    Program obnulenie;

    var a:array[1 ... 100,1 ... 100] of integer;

    i, j, n:integer;

    begin

    writeln ('Введите размер квадратной матрицы:') ;

    readln (n) ;

    writeln ('Введите матрицу:') ;

    for i:=1 to n do

    for j:=1 to n do

    begin

    read (a[i, j]) ;

    if j>i then a[i, j]:=0;

    end;

    writeln ('Измененная матрица:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы