Задать вопрос
28 октября, 06:46

Дано натуральное число n. чему равно сумма его цифр?

+2
Ответы (1)
  1. 28 октября, 08:51
    0
    Program sumcifr;

    uses crt;

    var

    n: longint;

    s: integer;

    j:integer;

    begin

    clrscr;

    s:=0; j:=0;

    write ('ввести число - - > ') ; readln (n) ;

    while n>0 do begin j:=j+1;

    s:=s+n mod 10;

    n:=n div 10;

    end;

    writeln ('число цифр числа = ', j) ;

    writeln ('сумма цифр числа = ', s) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число n. чему равно сумма его цифр? ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы