Задать вопрос
23 февраля, 23:22

Здравствуйте, помогите решить задачи по информатике.

Учусь я в 9 классе, так что многих основных сложных команд мы не изучали, пока вот остановились на while и do.

Вот сами задачи.

1. Составьте программу вычисления 2+4+6 ... + 200.

2. С клавиатуры вводятся шесть целых чисел. Определите количество чётных чисел в этом наборе.

Программы должны быть написаны на языке Pascal

В программах должен присутствовать цикл с предусловием, то есть while и do

+2
Ответы (1)
  1. 24 февраля, 00:17
    0
    1. program HelloWorld;

    var summ, i : integer;

    begin

    i:=2;

    while i<=200 do

    begin

    summ : = summ + i;

    i:=i+2;

    end;

    writeln (summ)

    end.

    2.

    program HelloWorld;

    var S, i, n: integer;

    begin

    while i<6 do

    begin

    writeln (' Введите значение число:') ;

    readln (S) ;

    if S mod 2 = 0 then n:=n+1;

    i:=i+1;

    writeln (n) ;

    end;

    writeln ('Количество четных:') ;

    writeln (n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Здравствуйте, помогите решить задачи по информатике. Учусь я в 9 классе, так что многих основных сложных команд мы не изучали, пока вот ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы